JCU Wireless Network Disruption
Incident Report for John Carroll University
Resolved
A fix has been applied to the network access system which seems to have corrected a problem that restricted some devices from connecting to the wireless network. It is important for you to contact the ITS Service Desk if you are still not able to connect as we want to ensure that everything is working correctly.

We appreciate your patience as we worked through this issue. Outage updates are also available on the ITS Status Page (https://status.jcu.edu).

--
Information Technology Services
Posted Aug 30, 2022 - 17:15 EDT
Investigating
Some users are experiencing issues connecting to the JCU wireless network. ITS is aware of the issue and working to restore service shortly. We apologize for the inconvenience. If you encounter any WiFi problems, please contact the Service Desk at 216-397-3005.

We are also seeing random power issues in some buildings. Please contact JCU facilities at 216-397-4314 if you see any power disruption in your area.
Posted Aug 30, 2022 - 11:52 EDT
This incident affected: Campus Notification and Network (Wired/Wireless) (Administration Building, Rodman Hall, Boler College of Business, O'Malley Center, Grasselli Library & Breen Learning Center, Dolan Science Center, Residence Halls, Everstream Internet Circuit, D.J. Lombardo Student Center, Schell House).