Network Outage
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Jul 20, 2022 - 12:17 EDT
Update
Campus Internet service was restored last night and should be fully functional. However, one of our internet providers was still working to repair a fiber cut in the area overnight and expects service to be restored today. When they complete these repairs we will again have fully redundant internet access.

If you are experiencing any issues with the campus network, or your Internet access, please contact the Service Desk at 216-397-3005 and we will investigate further.

We appreciate your patience as we worked through this issue. A disruption of this magnitude is not acceptable and we are working with our internet providers to ensure this does not happen again.

Outage updates are also available on the ITS Status Page (https://status.jcu.edu).
--
Information Technology Services
Posted Jul 20, 2022 - 08:29 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 19, 2022 - 23:55 EDT
Update
We are continuing to investigate this issue with both campus internet providers.
Posted Jul 19, 2022 - 23:01 EDT
Investigating
We are experiencing network issues on campus. Information Technology Services is aware of the problem and will post updates on our Status Page (https://status.jcu.edu/) as they become available.

We sincerely apologize for this situation and appreciate your patience. Please call the JCU Service Desk at 216-397-3005 for any questions or concerns you have.

--
Information Technology Services
216-397-3005
jcu.edu/its
Posted Jul 19, 2022 - 18:46 EDT
This incident affected: Campus Notification and Network (Wired/Wireless) (Administration Building, Rodman Hall, Boler College of Business, O'Malley Center, Grasselli Library & Breen Learning Center, Dolan Science Center, Residence Halls, Everstream Internet Circuit, D.J. Lombardo Student Center, Schell House).