Investigating System and Wi-Fi Issues on Campus [11/17/24]
Incident Report for John Carroll University
Resolved
The issue affecting Wi-Fi connectivity has been resolved. Both our team and vendor partners are actively monitoring the situation to ensure continued stability.

Thank you for your patience and understanding during this time. If you experience any further issues, please contact the Service Desk at 216-397-3005 or email servicedesk@jcu.edu.

--
Information Technology Services
Posted Nov 17, 2024 - 22:22 EST
Update
We’re actively working with the vendor to resolve the issue and appreciate your patience as we work to restore service as quickly as possible.
Posted Nov 17, 2024 - 18:42 EST
Investigating
We are aware of an issue currently affecting some systems and Wi-Fi connectivity. While the exact cause is still under investigation, our team is actively working to identify and resolve the problem as quickly as possible.

Updates will be available on the Status Page at https://status.jcu.edu.

If you have any questions or need assistance, please contact the Service Desk at 216-397-3005 or email servicedesk@jcu.edu.

Thank you for your patience.
--
Information Technology Services
Posted Nov 17, 2024 - 10:16 EST
This incident affected: Internet & Phones (Wireless Internet Connection) and Computer & Device Support (Virtual Desktops).