Information Technology Services has confirmed that Turnitin is now fully operational. The earlier issue has been resolved, and you should be able to access and use the service without disruption.
If you experience any further difficulties, please contact the Service Desk at 216-397-3005 or servicedesk@jcu.edu. . Thank you for your patience.
Posted Sep 10, 2025 - 15:56 EDT
Identified
Information Technology Services is aware of the issue affecting Turnitin and is working closely with the vendor to resolve it.
We will share updates as soon as additional information becomes available. Updates are also available on the ITS Status Page (https://status.jcu.edu).
If you have any questions or concerns, please contact the Service Desk at 216-397-3005 or servicedesk@jcu.edu.
Posted Sep 10, 2025 - 13:32 EDT
This incident affected: Teaching & Learning Tools (Turnitin).