Amazon Web Services Outage Causes Disruptions Across the Web
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Dec 16, 2021 - 10:49 EST
Investigating
Amazon Web Services is currently experiencing a significant event which temporarily disrupted some services including DUO multi-factor authentication. At this time all services appear to be functional. ITS will continue to monitor this situation.

Questions or comments? Please contact the ITS Service Desk at 216-397-3005 or servicedesk@jcu.edu. Updates are also available on the ITS Status Page (https://status.jcu.edu).

We appreciate your patience as ITS strives to maintain and improve the quality of the JCU services it supports.
--
Information Technology Services
Posted Dec 15, 2021 - 11:07 EST
This incident affected: Campus Notification.