Wireless Network Outage
Incident Report for John Carroll University
Resolved
Campus wireless service is restored and should be fully functional. We are monitoring the situation closely.

If you are experiencing any issues with the campus network, or your wireless connectivity, please contact the Service Desk at 216-397-3005 and we will investigate further.

We appreciate your patience as we worked through this issue. Outage updates are also available on the ITS Status Page (https://status.jcu.edu).
Posted Aug 23, 2022 - 21:53 EDT
Investigating
Some users are experiencing issues connecting to the JCU wireless network. Information Technology Services is aware of the problem and will post updates on our Status Page (https://status.jcu.edu/) as they become available.

We sincerely apologize for this situation and appreciate your patience. Please call the JCU Service Desk at 216-397-3005 for any questions or concerns you have.
Posted Aug 23, 2022 - 14:16 EDT
This incident affected: Campus Notification and Network (Wired/Wireless) (Administration Building, Rodman Hall, Boler College of Business, O'Malley Center, Grasselli Library & Breen Learning Center, Dolan Science Center, Residence Halls, Everstream Internet Circuit, D.J. Lombardo Student Center, Schell House).