Network Connectivity Issue
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Jan 11, 2025 - 12:39 EST
Monitoring
The network connectivity issue has been resolved. ITS has implemented a fix and is actively monitoring the situation to ensure it remains stable.

If you experience any connectivity issues, please contact the IT Service Desk at 216-397-3005 for assistance.
Posted Jan 10, 2025 - 11:25 EST
Investigating
We are currently experiencing intermittent network connectivity issues. ITS is aware of the problem and actively investigates the cause to ensure a prompt resolution.

If you have any questions or concerns, please contact the IT Service Desk at 216-397-3005.

For the more updates, please visit our Status Page at https://status.jcu.edu.

--
Information Technology Services
Posted Jan 10, 2025 - 08:32 EST
This incident affected: Internet & Phones (Wireless Internet Connection).