Canvas Outage

Incident Report for John Carroll University

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 13:43 EDT

Update

Canvas is still currently waiting for full recovery due to an ongoing AWS incident. You can follow the status of the issue at https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 15:49 EDT

Identified

Canvas is currently experiencing an outage due to an ongoing Amazon Web Services (AWS) incident. As a result, users may be unable to access courses or experience intermittent issues.

Information Technology Services (ITS) is closely monitoring the situation, and we will provide updates as soon as we receive more information from Canvas and AWS.

Thank you for your patience and understanding. If you have any questions or concerns, please contact the JCU Service Desk at 216-397-3005.

For the latest updates, please visit the ITS Status Page at https://status.jcu.edu.



Information Technology Services
Posted Oct 20, 2025 - 09:52 EDT
This incident affected: Teaching & Learning Tools (Canvas (Learning Management System)).