A fix has been implemented and we are monitoring the results.
Posted May 08, 2026 - 09:26 EDT
Update
Canvas remains unavailable at this time. Information Technology Services (ITS) continues to closely monitor the situation and work with Canvas regarding the ongoing outage.
We will provide another update before midnight, or sooner if additional information becomes available.
If you have any questions or need assistance, please contact the JCU Service Desk at 216-397-3005.
Thank you for your continued patience and understanding.
— Information Technology Services
Posted May 07, 2026 - 21:42 EDT
Investigating
Canvas is currently experiencing a service outage. As a result, users may be unable to access courses or may encounter intermittent issues while using the platform.
Information Technology Services (ITS) is aware of the situation and will share updates as soon as additional information becomes available from Canvas.
We appreciate your patience and understanding during this time. If you have questions or need assistance, please contact the JCU Service Desk at 216-397-3005.