Network Outage
Incident Report for John Carroll University
Monitoring
Information Technology Services (ITS) has identified the issue with our external network providers. We have deployed a series of patches and workarounds, and the campus network is now stable.

Please note that while the majority of services have been restored, some external services may still experience intermittent issues. We are actively monitoring the situation to ensure continued stability until the external network provider issues are fully resolved.

If you encounter any issues or have concerns, please contact the ITS Service Desk at 216-397-3005 for assistance.

Thank you for your patience and understanding.

Information Technology Services
Posted Dec 11, 2024 - 13:09 EST
Investigating
We are currently experiencing a disruption in the campus network, affecting wired and wireless as well as phone services. Our ITS engineers are actively working to resolve the issue as quickly as possible.

We sincerely apologize for this inconvenience and appreciate your patience and understanding. If you have any questions or concerns, please contact the JCU Service Desk at 216-397-3005.

For the latest updates, please visit the ITS Status Page at https://status.jcu.edu.

--
Information Technology Services
Posted Dec 11, 2024 - 11:28 EST
This incident affects: Internet & Phones (Wired Internet Connection, Wireless Internet Connection, Phones (VOIP)).