Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted 6 days ago. Mar 27, 2025 - 18:00 EDT
Scheduled
Information Technology Services will be performing scheduled maintenance on the Banner environment tonight, March 27, 2025, from 6:00 PM to 12:00 AM.
During this maintenance window, Banner applications and related services will be unavailable. For real-time updates, please visit the ITS Status Page (https://status.jcu.edu).
If you have any questions or concerns, feel free to contact the ITS Service Desk at servicedesk@jcu.edu.
Thank you for your patience and understanding as we work to enhance our systems.
— Information Technology Services
Posted 6 days ago. Mar 27, 2025 - 11:22 EDT
This scheduled maintenance affected: Enterprise Systems (Banner).