Important Cybersecurity Announcement
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Dec 28, 2021 - 21:55 EST
Investigating
A dangerous vulnerability was discovered in common web server software late last week and bad actors immediately began using it to launch cybersecurity attacks. In response, JCU ITS restricted off-campus access to some systems, including the IT ticketing system (Web Help Desk), and is investigating each campus web serving system for this vulnerability. It is possible that other systems will be restricted to on-campus access only or shut down as necessary to protect the campus. Individual vendors are releasing patches for their applications as quickly as possible and the affected systems will be upgraded as the patches become available.

ITS will continue to post updates, including system upgrade schedules, to the ITS Status Page: https://status.jcu.edu as mitigation efforts continue. A campus-wide email will only be sent out should any significant service restrictions be necessary.

Thank you for your consideration as ITS works through this most recent cybersecurity threat to our campus. Please direct any questions to the ITS Service Desk at 216-397-3005 or servicedesk@jcu.edu.
Posted Dec 13, 2021 - 11:25 EST
This incident affected: Campus Notification.