Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 08, 2022 - 17:00 EDT
Scheduled
Information Technology Services is scheduled to update the security certificate on our wireless (Eduroam) network on Friday, July 8th, 2022 at 5 pm.
After the upgrade, users may receive a prompt to accept the new security certificate. To continue to use Eduroam, follow OS-specific instructions on your device to accept the certificate and then connect as usual.
For assistance, please contact the ITS Service Desk at 216-397-3005 or servicedesk@jcu.edu. Maintenance updates are also available on the ITS Status Page (https://status.jcu.edu).
We appreciate your patience as ITS strives to maintain and improve the quality of the JCU services it supports. -- Information Technology Services
Posted Jul 05, 2022 - 17:07 EDT
This scheduled maintenance affected: Internet & Phones (Wired Internet Connection, Wireless Internet Connection, Everstream Internet Circuit) and Other.