Campus Wide Network Outage
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Nov 15, 2022 - 10:52 EST
Monitoring
Most of the campus internet service is restored and should be fully functional except for the library building.

If you are experiencing any issues with the campus network, or your Internet access, please contact the Service Desk at 216-397-3005 and we will investigate further.

Library network updates will be available through the ITS Status Page (https://status.jcu.edu).

We appreciate your patience as we worked through this issue.

--
Information Technology Services
Posted Nov 14, 2022 - 16:19 EST
Update
We are continuing to investigate this issue.
Posted Nov 14, 2022 - 15:33 EST
Investigating
We are experiencing a disruption in the campus network affecting both computer access and phones. ITS engineers are working with the vendor's Critical Response Team to resolve this issue as quickly as possible. Please know that this has the full and complete attention of the ITS team and the vendor's highest-level technical staff and executives.

We sincerely apologize for this situation and appreciate your patience. Please call the JCU Service Desk at 216-397-3005 for any questions or concerns you have.

Outage updates are also available on the ITS Status Page (https://status.jcu.edu).

--
Information Technology Services
Posted Nov 14, 2022 - 15:32 EST
This incident affected: Campus Notification and Network (Wired/Wireless) (Administration Building, Rodman Hall, Boler College of Business, O'Malley Center, Grasselli Library & Breen Learning Center, Dolan Science Center, Residence Halls, Everstream Internet Circuit, D.J. Lombardo Student Center, Schell House).