Scheduled Maintenance: Banner Environment

Incident Report for John Carroll University

Resolved

This incident has been resolved.
Posted Feb 23, 2025 - 14:53 EST

Investigating

As part of our ongoing cybersecurity efforts, Information Technology Services (ITS) will perform scheduled maintenance on the Banner environment on Sunday, February 23rd, from 8:00 AM to 11:00 AM.

During this time, some or all Banner services, including the Student Profile, Employee Dashboard, and Admin Pages will be unavailable.

If you have any questions or concerns, please contact the ITS Service Desk at servicedesk@jcu.edu or 216.397.3005.

For real-time maintenance updates, visit the ITS Status Page: https://status.jcu.edu.

Thank you for your patience and understanding as we continue to enhance our services.
Posted Feb 23, 2025 - 08:02 EST
This incident affected: Enterprise Systems (Banner).