Information Technology Services has implemented a fix for the network issue. All services should now be restored to normal.
We will continue to monitor the situation to ensure stability.
If you continue to experience any issues, please contact the Service Desk at 216-397-3005 for assistance.
Posted Mar 23, 2026 - 20:06 EDT
Update
We are continuing to monitor for any further issues.
Posted Mar 23, 2026 - 20:05 EDT
Monitoring
Information Technology Services has implemented a fix for the network issue. All services should now be restored to normal.
We will continue to monitor the situation to ensure stability.
If you continue to experience any issues, please contact the Service Desk at 216-397-3005 for assistance.
Posted Mar 23, 2026 - 20:01 EDT
Identified
Information Technology Services has identified the problem affecting network connectivity and is currently applying a fix.
We will continue to provide updates via the Status Page and email as progress is made.
If you have any questions or need assistance, please contact the Service Desk at 216-397-3005.
Posted Mar 23, 2026 - 19:53 EDT
Investigating
Information Technology Services is aware of the issue affecting network connectivity. Our network engineers are actively working to resolve it. Updates will be shared via the Status Page (status .jcu.edu) as they become available.
Questions or comments? Please contact the ITS Service Desk at 216-397-3005 or servicedesk@jcu.edu. Maintenance updates are also available on the ITS Status Page (https://status.jcu.edu).
-- Information Technology Services
Posted Mar 23, 2026 - 12:14 EDT
This incident affected: Internet & Phones (Wired Internet Connection, Wireless Internet Connection).