Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 18, 2023 - 18:02 EDT
Scheduled
Information Technology Services will be installing patches and updates to the Banner environment tonight (October 18th, 2023) between 6 pm and midnight.
During this maintenance window, Banner applications and related services will be unavailable. Maintenance updates are available on the ITS Status Page (https://status.jcu.edu).
Questions or comments? Please send an email to the ITS Service Desk: servicedesk@jcu.edu.
Thank you for your patience and understanding while we work to improve our services.
-- Information Technology Services
Posted Oct 18, 2023 - 09:41 EDT
This scheduled maintenance affected: Enterprise Systems (Banner).