Banner Maintenance
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Jan 24, 2023 - 17:06 EST
Investigating
Banner will be briefly unavailable starting at 5pm this evening. The maintenance is not expected to last more than 10 minutes.
Posted Jan 24, 2023 - 16:51 EST
This incident affected: Enterprise Systems (Banner).