Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 06, 2024 - 01:00 EDT
Scheduled
Qualtrics is migrating the dashboards, results reports, and printed reports layout database to a cloud-managed database in the North America region. This move helps improve the North America region's performance, scalability, and reliability.
If you are still experiencing issues with reports and dashboards after the maintenance window has ended, please contact the ITS Service Desk at 216.397.3005.
Posted Sep 18, 2024 - 15:49 EDT
This scheduled maintenance affected: Teaching & Learning Tools (Qualtrics).