IT Systems Connectivity Issues
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Apr 28, 2020 - 09:27 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 27, 2020 - 18:53 EDT
Investigating
We are currently investigating this issue.
Posted Apr 27, 2020 - 17:48 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 27, 2020 - 14:17 EDT
Investigating
Some users are experiencing timeouts and page errors when attempting to access Banner and other systems behind Single Sign-On and connecting it through VPN. Our team is currently looking into this issue and we will provide updates as they become available on status.jcu.edu.

We appreciate your continued patience and support. Please contact the ITS Service Desk at 216-397-3005 with any questions or concerns.

Information Technology Services
jcu.edu/its
216-397-3005
Posted Apr 27, 2020 - 13:27 EDT
This incident affected: Enterprise Systems (Banner) and Accounts, Passwords and Identity (JCU Login Page & Single Sign On (SSO)).