Users are reporting page errors when attempting to access Canvas
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Mar 25, 2021 - 10:30 EDT
Update
We are continuing to monitor for any further issues.
Posted Mar 25, 2021 - 10:03 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2021 - 09:34 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 25, 2021 - 09:12 EDT
Investigating
We are aware that some users are experiencing issues when attempting to connect to Canvas. Canvas (Instructure) is working to resolve the issue as quickly as possible. We will post another update once know more about the scope and impact of this outage - or if the issue is resolved.

Please contact the Service Desk at 216-397-3005 if you have any questions or concerns.
Posted Mar 25, 2021 - 08:54 EDT
This incident affected: Teaching & Learning Tools (Canvas).