[Postmortem] Single Sign-On (SSO) Brief Service Outage
Incident Report for John Carroll University
Resolved
Information Technology Services experienced a brief outage on our Single Sign-On (SSO) environment where users were not able to log in for a couple of minutes. A fix has been implemented and we are monitoring the results.

Please call the JCU Service Desk at 216-397-3005 if you are still having issues login into any of the services.
--
Information Technology Services
Posted Nov 23, 2022 - 17:30 EST