Self Service Password Change Emergency maintenance
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Aug 08, 2022 - 12:00 EDT
Identified
The server which houses Self Service Password Change and some other services will be undergoing emergency maintenance between 7-9pm this evening. During this time, Password Change and other services may be unavailable.
Posted Aug 07, 2022 - 19:02 EDT