Schell house power outage
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Dec 11, 2021 - 09:33 EST
Update
We are continuing to investigate this issue.
Posted Dec 10, 2021 - 16:04 EST
Investigating
Schell house is currently experiencing a power issue, it will restored within about 2 hours. We will update as soon as more information is available
Posted Dec 10, 2021 - 12:36 EST
This incident affected: Network (Wired/Wireless) (Schell House).