Canvas Third-Party Tools Outage

Incident Report for John Carroll University

Resolved

ITS has confirmed that the issue affecting access to third-party tools within Canvas (including LockDown Browser, Turnitin, and others) has been resolved.

We appreciate your patience while Instructure and ITS worked to resolve this issue. Please contact the Service Desk at 216-397-3005 if you continue to experience any problems.
Posted May 05, 2026 - 12:38 EDT

Investigating

We are currently investigating this issue.
Posted May 04, 2026 - 09:46 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 07, 2026 - 09:02 EDT

Investigating

Information Technology Services (ITS) is aware of an issue impacting access to third-party tools within Canvas, including LockDown Browser, Turnitin, and others.

Users may encounter errors when attempting to launch these tools. As a result, some students are unable to access exams that require LockDown Browser.

Instructure (the Canvas vendor) is aware of the issue. ITS has opened a support case and is actively working to escalate the resolution.

We will provide updates as more information becomes available.
Posted May 02, 2026 - 19:59 EDT
This incident affected: Teaching & Learning Tools (Canvas (Learning Management System), Turnitin, Respondus Lockdown Browser & Monitor).