Issues with VoIP Phones
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Aug 27, 2021 - 17:16 EDT
Investigating
We are currently experiencing an issue with University VoIP Phones. We are working with our vendor and will post updates on our ITS Status Page as they become available.

We sincerely apologize for this situation and appreciate your patience. If you have any questions or are experiencing issues with phones, please contact the JCU Service Desk at 216-397-3005.

Information Technology Services
Posted Aug 27, 2021 - 09:56 EDT
This incident affected: Other Applications (Phones (VOIP)).