Zoom Service Disruption [4/16/25]

Incident Report for John Carroll University

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 16, 2025 - 17:10 EDT

Investigating

Zoom is currently experiencing a widespread service disruption impacting meetings, Zoom’s website, certain features within the desktop application, and some JCU phones.

At this time, Zoom has not provided an estimated timeframe for service restoration. We will continue to share updates as they become available.

If you have any questions or concerns, please contact the IT Service Desk at 216-397-3005. For the latest updates, visit our status page at status.jcu.edu.

--
Information Technology Services
Posted Apr 16, 2025 - 15:42 EDT
This incident affects: Enterprise Systems (Zoom Application, Zoom Meetings, Zoom Rooms).