WebHelpDesk (helpdesk.jcu.edu) requires VPN to access the system off campus
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Dec 11, 2021 - 19:22 EST
Investigating
If you are trying to access WebHelpDesk (helpdesk.jcu.edu) to create a ticket for the ServiceDesk off-campus, please use the VPN before you connect to the WebHelpDesk.

ITS is aware of the problem and is investigating, and will post updates on our ITS Status Page (https://status.jcu.edu/) as they become available.

Please call the JCU Service Desk at 216-397-3005 for any questions or concerns you have.
Posted Dec 11, 2021 - 11:02 EST
This incident affected: Enterprise Systems (TeamDynamix (Ticketing System)).