Google is reporting a service outage across all their products including Gmail and all Google Apps.
Incident Report for John Carroll University
Resolved
The problem with Google and Gmail has been resolved. We apologize for the inconvenience and thank you for your patience and continued support.
Posted Dec 14, 2020 - 09:19 EST
Identified
The problem with Google services should be resolved for the vast majority of affected users. Google will provide updated information on their status page (https://www.google.com/appsstatus).

Please call the Service Desk at 216-397-3005 if you have any questions or concerns.
Posted Dec 14, 2020 - 08:54 EST
Investigating
Google is reporting a service outage across all their products including Gmail and all Google Apps.
Posted Dec 14, 2020 - 07:30 EST
This incident affected: Email, Calendar and Other Google Applications (Google Apps Gmail, Google Apps Drive, Google Apps Slides, Google Apps Sheets, Google Apps Calendar, Google Apps Docs).