Printers Outage
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Sep 23, 2021 - 17:17 EDT
Update
Microsoft security patches were applied to the John Carroll University print server over the weekend to address known vulnerabilities. Despite prior testing, the patch prevented many on campus from printing.

Due to the significant disruption in campus operations, Information Technology Services (ITS) will be returning the print server to its pre-patched configuration this evening at 5:15 pm. This process will take up to one hour, during which you will be unable to access printers connected to the print server.

As soon as it is practical, ITS will begin rolling out patches to individual workstations, which will allow them to function once these important print server updates are re-applied.

Thank you for your patience as we continue to keep our campus computing environment safe!

If you have any questions, contact the ITS Service Desk at servicedesk@jcu.edu or 216-397-3005.
Posted Sep 21, 2021 - 15:34 EDT
Identified
Some users are still not able to print. We sincerely apologize for this situation and appreciate your patience. Please call the JCU Service Desk at 216-397-3005 for any questions or concerns you have.
Posted Sep 20, 2021 - 14:08 EDT
Update
Some users are still not able to print. We sincerely apologize for this situation and appreciate your patience. Please call the JCU Service Desk at 216-397-3005 for any questions or concerns you have.
Posted Sep 20, 2021 - 14:08 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 20, 2021 - 09:49 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 20, 2021 - 09:44 EDT
Investigating
All printers are currently unavailable due to unexpected software/configuration issues.

We are aware of the problem and provide updates as they become available on our ITS Status Page (https://status.jcu.edu/).

We sincerely apologize for this situation and appreciate your patience. Please call the JCU Service Desk at 216-397-3005 for any questions or concerns you have.

Information Technology Services
216-397-3005
Posted Sep 20, 2021 - 09:01 EDT
This incident affected: Computer & Device Support (Printers).