Banner Service Disruption

Incident Report for John Carroll University

Resolved

This incident has been resolved.
Posted Mar 04, 2025 - 16:13 EST

Monitoring

The issue with our Banner environment has been resolved, and the system is now fully operational. Information Technology Services will continue to monitor performance to ensure stability.

If you experience any further issues, please check our Status Page ( (https://status.jcu.edu/) for updates or contact the JCU Service Desk at 216-397-3005.

Thank you for your patience and understanding.
--
Information Technology Services
Posted Mar 04, 2025 - 13:17 EST

Investigating

We are currently experiencing an issue with our Banner environment. Information Technology Services is aware and actively working on a resolution. Updates will be posted on our Status Page (https://status.jcu.edu/) as they become available.

We apologize for the inconvenience and appreciate your patience. For any questions or concerns, please contact the JCU Service Desk at 216-397-3005.
--
Information Technology Services
Posted Mar 04, 2025 - 12:41 EST
This incident affected: Enterprise Systems (Banner).