Network Disruption: Fairmount Apartments
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Nov 09, 2024 - 20:59 EST
Investigating
Information Technology Services (ITS) is aware of the network disruption affecting the Fairmount apartment buildings. We are actively working to identify the source and will provide updates as soon as we have more information.

If you have any questions, please contact the IT Service Desk at 216-397-3005.
Posted Nov 09, 2024 - 08:26 EST
This incident affected: Internet & Phones (Wireless Internet Connection).