WebHelpDesk Service Disruption
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Feb 05, 2022 - 20:14 EST
Investigating
WebHelpDesk is currently having issues. We are aware of the problem and provide updates as they become available on our ITS Status Page (https://status.jcu.edu/).

We sincerely apologize for this situation and appreciate your patience. Please call the JCU Service Desk at 216-397-3005 for any questions or concerns you have.

Information Technology Services
216-397-3005
Posted Feb 05, 2022 - 14:24 EST
This incident affected: Other Applications (WebHelpDesk (Ticketing System)).