Gmail - Degraded Performance
Incident Report for John Carroll University
Resolved
Gmail service has already been restored for some users, and we expect a resolution for all users in the near future. Please note this time frame is an estimate and may change. The affected users are able to access Gmail, but may experience delays in sending or receiving messages.
Posted Apr 08, 2020 - 11:54 EDT
Investigating
Google is investigating reports of an issue with Gmail. We will provide more information shortly.
Posted Apr 08, 2020 - 11:34 EDT
This incident affected: Email, Calendar and Other Google Applications (Google Apps Gmail).