Self Service Password Change is Down
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Dec 11, 2021 - 19:22 EST
Investigating
We are currently experiencing an issue accessing the Self-Service Password Change environment. This will affect the ability to change your password yourself.

We are aware of the problem and provide updates as they become available on our ITS Status Page (https://status.jcu.edu/).

We sincerely apologize for this situation and appreciate your patience. Please call the JCU Service Desk at 216-397-3005 for any questions or concerns you have.

Information Technology Services
Posted Dec 11, 2021 - 11:08 EST
This incident affected: Accounts, Passwords and Identity (JCU Login Page & Single Sign On (SSO)).