Banner Service Disruption
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Sep 01, 2022 - 17:34 EDT
Investigating
We are currently experiencing an issue with our Banner environment. Information Technology Services is aware of the problem and will post updates on our Status Page (https://status.jcu.edu/) as they become available.

We sincerely apologize for this situation and appreciate your patience. Please call the JCU Service Desk at 216-397-3005 for any questions or concerns you have.

--
Information Technology Services
Posted Sep 01, 2022 - 17:07 EDT
This incident affected: Other Applications (Banner).