Some Canvas users are experiencing slowness or occasional page errors.
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Dec 08, 2021 - 09:06 EST
Monitoring
The majority of areas impacted by this outage have returned to normal function. We will continue monitoring Canvas as it returns to normal functionality as well as updating this status page as more information becomes available.
Posted Dec 07, 2021 - 22:18 EST
Identified
Current disruptions with Amazon Web Services are impacting Canvas and related tools including Respondus Lockdown Browser causing them to be slow or inaccessible. We are currently monitoring the situation and will provide updates as we receive them.
Posted Dec 07, 2021 - 16:47 EST
Investigating
Some Canvas users are experiencing slowness or occasional page errors (504 Gateway Time-out) when accessing Canvas. Canvas is aware of the problem and is investigating, and will post updates on our ITS Status Page (https://status.jcu.edu/) as they become available.

We sincerely apologize for this situation and appreciate your patience. Please call the JCU Service Desk at 216-397-3005 for any questions or concerns you have.

More information can be found on the Instructure status page (https://status.instructure.com/).
Posted Dec 07, 2021 - 16:37 EST
This incident affected: Teaching & Learning Tools (Canvas).