Software Center can not be loaded.
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Jun 03, 2021 - 11:58 EDT
Update
We are continuing to work on a fix for this issue.
Posted May 19, 2021 - 11:34 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 17, 2021 - 11:12 EDT
Investigating
JCU Software Center is not working currently. ITS is aware of the problem and is investigating. Please contact the ITS Service Desk at x3005 or servicedesk@jcu.edu with any questions or concerns.

Information Technology Services
216-397-3005
Posted May 17, 2021 - 10:25 EDT
This incident affected: Other Applications (Software Center).