Degree Works Experiencing Submission Error

Incident Report for John Carroll University

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 08:53 EDT

Investigating

We have received reports that Degree Works is currently showing an error message when trying to submit registrations. We are investigating the issue and will update shortly.
Posted Oct 28, 2025 - 07:52 EDT