Power-Related Network Issue – DSC (West Side)

Incident Report for John Carroll University

Investigating

We are currently experiencing power-related network issues affecting the west side of the Dolan Science Center (DSC). As a result, some users in that area may experience intermittent or unavailable network connectivity.

Information Technology Services is aware of the issue and is actively working to restore services as quickly as possible.

Updates will be posted as more information becomes available.

Thank you for your patience.
Posted Mar 13, 2026 - 14:27 EDT
This incident affects: Internet & Phones (Wired Internet Connection, Wireless Internet Connection).