The issue has been resolved. If you are still experiencing any problems with campus network or wireless connectivity, please contact the Service Desk at 216-397-3005 at your earliest convenience. Thank you for your patience.
Posted Oct 31, 2024 - 14:58 EDT
Investigating
We are currently experiencing network issues across several buildings on campus due to a power failure. Affected buildings include Rodman, SIH, O'Malley Center, Boler College of Business, and potentially others. We are actively working to restore connectivity as soon as possible.
Thank you for your patience and understanding.
Posted Oct 31, 2024 - 12:12 EDT
This incident affected: Internet & Phones (Wired Internet Connection, Wireless Internet Connection).