JCUDigitalPortal Outage
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Mar 29, 2023 - 15:24 EDT
Investigating
We are experiencing an issue with JCUDigitalPortal. Users can login to the virtual desktop but receiving a connection refused error.

ITS is investigating the problem and we will provide updates as they become available.

Please call the JCU Service Desk at 216-397-3005 for any questions or concerns you have.

Information Technology Services
216-397-3005
Posted Mar 29, 2023 - 09:00 EDT
This incident affected: Other.