Intermittent Issue with SpeedGrader Previews in Canvas
Incident Report for John Carroll University
Resolved
This incident has been resolved.

If you are still seeing this message when attempting to preview a document in Canvas, please try logging out of Canvas, clearing your browser’s cache, closing your browser, opening your browser again, logging back into Canvas at canvas.jcu.edu, and previewing the document again.

If the issue persists after following these steps, please call 216-397-3005 for assistance.

We apologize for any inconvenience this issue may have caused. Thank you for waiting for a resolution to this issue.
Posted May 13, 2022 - 13:13 EDT
Update
We are continuing to monitor for any further issues.
Posted May 13, 2022 - 12:04 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 13, 2022 - 12:03 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 13, 2022 - 10:49 EDT
Investigating
Canvas Users may experience periodic "Service is currently unavailable. Try again later." messages when utilizing Speedgrader or previewing documents.

ITS is aware of the problem and is investigating. We will post updates as they become available from Canvas.

Please call the JCU Service Desk at x3005 for any questions or concerns you have.

Information Technology Services
216-397-3005
Posted May 13, 2022 - 10:09 EDT
This incident affected: Teaching & Learning Tools (Canvas (Learning Management System)).