Printers Outage
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Jan 04, 2021 - 15:30 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 04, 2021 - 13:57 EST
Investigating
All printers are currently unavailable due to unexpected software/configuration issues.

We are aware of the problem and provide updates as they become available on our ITS Status Page (https://status.jcu.edu/).

We sincerely apologize for this situation and appreciate your patience. Please call the JCU Service Desk at 216-397-3005 for any questions or concerns you have.

Information Technology Services
216-397-3005
Posted Jan 04, 2021 - 09:58 EST
This incident affected: Other Applications (Printers).