Turnitin: Submissions & Similarity Reports not viewable
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Dec 09, 2020 - 14:39 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 09, 2020 - 12:47 EST
Investigating
Turnitin.com and Turnitinuk.com are currently experiencing unexpected service degradation. During this time, you may find that you are unable to view submissions and/or Similarity Reports.

We will update the status page once we have verified that the service has been restored.

If you have any questions or concerns, please call the JCU Service Desk at 216-397-3005. We apologize for the inconvenience.
Posted Dec 09, 2020 - 10:48 EST
This incident affected: Teaching & Learning Tools (Turnitin).