We are continuing to monitor for any further issues.
Posted Apr 07, 2025 - 11:36 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 07, 2025 - 11:36 EDT
Investigating
We are currently experiencing an issue with our Banner environment. Information Technology Services is aware and actively working on a resolution. Updates will be posted on our Status Page (https://status.jcu.edu/) as they become available.
We apologize for the inconvenience and appreciate your patience. For any questions or concerns, please contact the JCU Service Desk at 216-397-3005. -- Information Technology Services
Posted Apr 07, 2025 - 11:02 EDT
This incident affected: Enterprise Systems (Banner).