Hamlin Hall Power Issues
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Feb 09, 2022 - 08:17 EST
Investigating
There is a power issue affecting Hamlin Hall. This is affecting all network services in Hamlin.
Posted Feb 09, 2022 - 08:05 EST
This incident affected: Network (Wired/Wireless) (Residence Halls).