Important: JCU NETWORK OUTAGE
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Jul 27, 2022 - 15:49 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 27, 2022 - 12:04 EDT
Investigating
We are experiencing some network issues on campus. Information Technology Services is aware of the problem and will post updates on our Status Page (https://status.jcu.edu/) as they become available.

We sincerely apologize for this situation and appreciate your patience. Please call the JCU Service Desk at 216-397-3005 for any questions or concerns you have.

--
Information Technology Services
216-397-3005
jcu.edu/its
Posted Jul 27, 2022 - 11:23 EDT
This incident affected: Campus Notification and Network (Wired/Wireless) (Administration Building, Rodman Hall, Boler College of Business, O'Malley Center, Grasselli Library & Breen Learning Center, Dolan Science Center, Residence Halls, Everstream Internet Circuit, D.J. Lombardo Student Center, Schell House).