Telephone Issues in Dolan Science Center East Wing
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted May 10, 2022 - 09:02 EDT
Investigating
We are currently investigating this issue. Please call the JCU Service Desk at x3005 for any questions or concerns you have.

We will post updates as they become available.
Posted May 10, 2022 - 08:47 EDT
This incident affected: Other Applications (Phones (VOIP)).