OnBase is Unavailable
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Dec 14, 2020 - 17:29 EST
Investigating
JCU's OnBase instance is currently unavailable. We are working with the vendor to resolve the issue.
Posted Dec 14, 2020 - 12:55 EST
This incident affected: Other Applications (OnBase).